Does NationBuilder support Authorize.net's migration to TLS 1.2?

We received an email from Authorize asking to confirm whether NationBuilder's API supports Authorize.net's migration to TLS 1.2. Does it?

Authorize.Net

 

Important TLS Disablement Notice

Your Payment Gateway ID: 
Dear Authorize.Net Merchant:

As you may be aware, new PCI DSS requirements state that all payment systems must disable early TLS by 2018. Transport Layer Security (TLS), is a technology used to encrypt sensitive information sent via the Internet. TLS is the replacement for Secure Sockets Layer (SSL).

In preparation for this requirement, Authorize.Net plans to disable TLS 1.0 and TLS 1.1 on the following dates:

Production: September 18, 2017


Please contact your web developer or payment solution provider, as well as your web hosting company, to confirm that they can support TLS 1.2 for your API connections.

In addition, we plan to retire the 3DES cipher (a data encryption standard) in production soon. However, the date has not yet been finalized. We will notify you once it has.

Please refer your developer or solution provider to our API Best Practices for cipher recommendations, details about TLS 1.2 platform support, and other integration suggestions.

Note: If you are not using the current version of your web browser, please take a few moments to upgrade it now. Browsers released prior to 2014 may not support TLS 1.2. You can check your browser's TLS support by visiting https://www.howsmyssl.com/.

Thank you for your attention to this matter and for being an Authorize.Net merchant.

Sincerely,
Authorize.Net
You have opted to receive Administrative and/or Technical Notices for your payment gateway account. To unsubscribe, log into the Merchant Interface and click Account from the main toolbar. Then click User Profile from the menu on the left. Select Edit Profile Information and uncheck the email types you do not want to receive. Click Submit to save any changes.

For information on Authorize.Net communications and how we handle customer information, please see our Spam Policy and Privacy Policy.

Copyright 2017. Authorize.Net. P.O. Box 8999, San Francisco, CA 94128-8999. All rights reserved. All other marks are the property of their respective owners.
Official response from

Yes, NationBuilder supports TLS 1.2 connections to Authorize.net! Your NationBuilder service will not be impacted by the upcoming TLS changes by Authorize.net.

Complete and current information on how to use NationBuilder is available in the documentation section.

Share this post

Showing 4 reactions

How would you tag this suggestion?
Please check your e-mail for a link to activate your account.